Maybe and issues with WebGrease or just wrong .Net Version

Jul 12, 2013 at 3:39 PM
Edited Jul 12, 2013 at 5:21 PM
Hi

I am using ASP.MVC 4 on .NET 4.0 (NOT 4.0.3).

I receive the following warning using the ASP.Net Compiler:

"D:\Development\SCCProjectInspiration\SystemControlCenter\SCC.build" (default t
arget) (1) ->
"D:\Development\SCCProjectInspiration\SystemControlCenter\SystemControlCenter.s
ln" (default target) (2) ->
"D:\Development\SCCProjectInspiration\SystemControlCenter\SystemControlCenter\S
ystemControlCenter.csproj" (default target) (3) ->
(AspNetPreCompile target) ->
ASPNETCOMPILER : warning : The following assembly has dependencies on a versi
on of the .NET Framework that is higher than the target and might not load corr
ectly during runtime causing a failure: WebGrease, Version=1.3.0.0, Culture=neu
tral, PublicKeyToken=31bf3856ad364e35. The dependencies are: System.Windows.For
ms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089. You shou
ld either ensure that the dependent assembly is correct for the target framewor
k, or ensure that the target framework you are addressing is that of the depend
ent assembly. [D:\Development\SCCProjectInspiration\SystemControlCenter\SystemC
ontrolCenter\SystemControlCenter.csproj]
1 Warning(s)
0 Error(s)
I use Webgrease as a dependency of Microsoft.AspNet.Web.Optimization package.
Is it possible that Webgrease requires .NET 4.5 or should i put an assembly redirect directive in my web.config or is this a bug in WebGrease?

Thanks